1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sallos

Discussion in 'News Archive' started by Staff, Oct 13, 2014.

  1. Derwolf

    Derwolf Well-Known Member

    2,122
    1,851
    113
    Aug 6, 2014
    i made a folder on my desktop called dx9 and extracted all the files into there
     
  2. Galth

    Galth Member

    7
    2
    0
    Jul 1, 2016
    Galthran
    Hey everyone,

    Please help me a bit.

    I installed UOF client and followed the steps in that video:

    View: https://www.youtube.com/watch?v=q1VZep1gFlA


    ... then I downloaded Sallos from here:
    http://www.uoforever.com/patches/Sallos/Sallos.zip
    ... unzipped it, and configured the UOF client sallos directory from the settings menu.

    Unfortunatelly, when I start up the game with Sallos, I get "Connection lost" message each time I try to log in.

    Then I installed UO from uo.com and I patched it all the way, and configured the UOF launcher base dir to point to it.
    Still getting the same issue. In Sallos logs I see this;


    Entered Main()
    Environment..
    Operating System = 'Microsoft Windows NT 6.2.9200.0'
    .NET Framework = '4.0.30319.42000'
    Base Directory = 'D:\Games\UO\Sallos'
    Data Directory = 'D:\Games\Electronic Arts\Ultima Online Classic'
    Done
    Main()..
    Initializing Display...done
    Initializing DirectX..
    Fullscreen = False
    Done
    Reading art.def......done
    Reading body.def......done
    Reading corpse.def......done
    Reading gump.def......done
    Reading sound.def......done
    Reading music.def......done
    Reading texterr.def......done
    Reading anim1.def......done
    Reading anim2.def......done
    Reading anim3.def......done
    Reading anim4.def......done
    Reading anim5.def......done
    LoadArchivedTexture( "graphics/gold_dragon.png" ) failed
    Initializing Map...done ( 00:00:00.0323980 )
    Initializing Animations...done ( 00:00:00.0023243 )
    Initializing Gumps...done ( 00:00:00.0008293 )
    Initializing Hues...done ( 00:00:00.0030048 )
    Connecting to 5.254.90.146:****
    Graceful disconnect
    Done


    Any ideas?

    Best regards,
    Marin
     
    Last edited by a moderator: Jul 3, 2016
  3. Sin Semilla

    Sin Semilla Active Member

    25
    8
    0
    Jun 1, 2016
    Sin Semilla
    Doobage
    Panama
    The Devils Hands

    Exact same problem,
     
  4. Sin Semilla

    Sin Semilla Active Member

    25
    8
    0
    Jun 1, 2016
    Sin Semilla
    Doobage
    Panama
    The Devils Hands
    Uninstalled UO, deleted EA folder. Installed fresh using UOForever launcher and issue was resolved.
     
  5. Nidhoggur

    Nidhoggur Well-Known Member

    101
    87
    0
    Jul 28, 2016
    Nidhoggur, Jita Four-Four, Omen NI,
    Disregard
     
    Last edited by a moderator: Aug 24, 2016
  6. Skyline

    Skyline New Member

    4
    4
    0
    Oct 16, 2016
    Installed everything according to the directions but i cant seem to get sallos to load. It seems to go but then a UO window pops up and says connection lost. Have reinstalled everything several times but same thing happens. Can log in fine through razor and UOS . Any ideas how to fix that?

    Thanks!
     
  7. drasked

    drasked Well-Known Member

    1,539
    2,712
    113
    Oct 7, 2015
    www.uoforever.com/patches/Sallos/data.zip
     
    3 people like this.
  8. Skyline

    Skyline New Member

    4
    4
    0
    Oct 16, 2016
    Yea i figured it out just now, thanks a lot for the response.
     
  9. Alucard

    Alucard Well-Known Member

    986
    911
    93
    Dec 29, 2013
    unfortunately, admins not always update topics
    need find solution searching on forum
    http://www.uoforum.com/threads/sallos-isnt-working.86953/#post-662390

    here info how to fix it:
    Make sure you are using this sallos:
    www.uoforever.com/patches/Sallos/Sallos.zip

    And apply this fix:
    copy and update in sallos folder
    www.uoforever.com/patches/Sallos/data.zip

    p.s @drasked was faster ))
     
    3 people like this.
  10. Skyline

    Skyline New Member

    4
    4
    0
    Oct 16, 2016
    2 people like this.
  11. Dan is here.

    Dan is here. Well-Known Member

    170
    73
    28
    Nov 12, 2016
    none
    this needs to be set as main post....JUST saved me so much stress if only in the original post did it say you had to dorp an updated data file into teh sallos download..... man...but this 1000% yes
     
    2 people like this.
  12. m1splaced

    m1splaced Member

    22
    13
    3
    Nov 27, 2016
    Talys
    Hmmmm...any idea what to do with this one?

    System.IndexOutOfRangeException: Index was outside the bounds of the array.
    at PlayUO.Hues.GetItemHue(Int32 itemID, Int32 hue)
    at PlayUO.StaticItem..ctor(HuedTile tile, Int32 influence, Int32 serial)
    at PlayUO.StaticItem.Instantiate(HuedTile tile, Int32 influence, Int32 serial)
    at PlayUO.Map.GetMap(Int32 X, Int32 Y, Int32 W, Int32 H)
    at PlayUO.Renderer.FindTileFromXY(Int32 mx, Int32 my, Int32& TileX, Int32& TileY, Boolean onlyMobs)
    at PlayUO.Engine.MouseMoveQueue()
    at Injection.Seed.MainA()
    at Injection.Seed.Initialize()
     
  13. Bovich

    Bovich Member

    13
    12
    3
    Oct 2, 2015
    Hey everyone, I'm getting the message "PlayUO has encountered an error and must close."

    and the details :
    System.TypeInitializationException: The type initializer for 'PlayUO.Profiles.Config' threw an exception. ---> System.NullReferenceException: Object reference not set to an instance of an object.
    at Sallos.XmlPersistanceReader.GetChild()
    at PlayUO.Profiles.Config.DeserializeChildren(PersistanceReader ip)
    at Sallos.PersistableObject.Deserialize(PersistanceReader ip)
    at PlayUO.Profiles.Config.Load()
    at PlayUO.Profiles.Config..cctor()
    --- End of inner exception stack trace ---
    at PlayUO.Profiles.Profile.get_Current()
    at Injection.Seed.MainA()
    at Injection.Seed.Initialize()

    i have reinstalled, used the new sallos updates of the 'data' files and the other links you guys posted here, with no success.
    Thanks in advance!


    Okay so I read more and more in this thread and the solution is to delete the config file on appdata/local/sallos.
    I'll leave this here if anyone else has this problem.
     
  14. Alucard

    Alucard Well-Known Member

    986
    911
    93
    Dec 29, 2013
    try download and install directx from microsoft
    and you can try download this Sallos
    SALLOS :
    https://www.dropbox.com/s/szyk91syompi5b4/Sallos.zip?dl=0
     
  15. Monocheddar

    Monocheddar New Member

    2
    0
    0
    Jun 26, 2014
    Hi i have issues running the Sallos client, I keep getting two errors after trying to launch Sallos via UOFlauncher: ( i also get the same errors when i try to launch it standalone )

    Error 1

    System.ApplicationException: Unable to create Direct3D device. ---> SharpDX.SharpDXException: HRESULT: [0x8876086A], Module: [SharpDX.Direct3D9], ApiCode: [D3DERR_NOTAVAILABLE/NotAvailable], Message: Unknown

    Error 2

    System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ApplicationException: Unable to create Direct3D device. ---> SharpDX.SharpDXException: HRESULT: [0x8876086A], Module: [SharpDX.Direct3D9], ApiCode: [D3DERR_NOTAVAILABLE/NotAvailable], Message: Unknown

    I sheared the error messages, complete versions can be found here: https://justpaste.it/14c1z


    I run windows 7 and have installed directX that was provided by Shane, and also have downloaded Sallos and updated it with data.zip also from this thread.

    I also tried:
    – running both Sallos and UOFlauncher as admin.
    – fully update uo via uopatcher and then with UOFlauncher patch feature
    – running in win xp sp 3 compatiblity mode
    – reinstalling UO with UOFinstaller
    – reinstalling Sallos client, by deleting it and extracting the .zip again

    Also here's a screenshot from dxdiag
    [​IMG]
     
  16. MrTwoTimez

    MrTwoTimez Active Member

    27
    0
    1
    Apr 23, 2017
    My sallos error message reads as followed. Anyone have any ideas?

    System.ArgumentNullException: Value cannot be null.
    Parameter name: soundDevice
    at PlayUO.Assets.PhysicalAudioProvider..ctor(DirectSound soundDevice)
    at PlayUO.Sounds..ctor()
    at PlayUO.PacketHandlers.PlaySound(PacketReader pvSrc)
    at PlayUO.NetworkContext.Cycle()
    at PlayUO.Network.Slice()
    at Injection.Seed.MainA()
    at Injection.Seed.Initialize()
     
  17. Doomtrooper

    Doomtrooper Member

    5
    4
    3
    Mar 26, 2017
    • Enemies on map are red dots.
    No dude, that's cheating. The standard "map" in UO has never been very helpful. It certainly doesn't allow you any advantages in finding enemies. You are all cheaters.
     
  18. link

    link Member

    7
    15
    3
    Jun 5, 2013
    Its an advanced map compared to the original, the dots are only present when they are on your screen.
     
  19. HighIntentions

    HighIntentions Member

    9
    0
    1
    Apr 21, 2013
    This is my playuo.log C:\Program Files (x86)\Electronic Arts\Ultima Online Classic\Sallos\data\ultima\logs

    Entered Main()
    Environment..
    Operating System = 'Microsoft Windows NT 6.1.7601 Service Pack 1'
    .NET Framework = '4.0.30319.42000'
    Base Directory = 'C:\Program Files (x86)\Electronic Arts\Ultima Online Classic\Sallos'
    Data Directory = 'C:\Program Files (x86)\Electronic Arts\Ultima Online Classic'
    Done
    Main()..
    Initializing Display...done
    Initializing DirectX..
    Fullscreen = False
    Done
    Reading art.def......done
    Reading body.def......done
    Reading corpse.def......done
    Reading gump.def......done
    Reading sound.def......done
    Reading music.def......done
    Reading texterr.def......done
    Reading anim1.def......done
    Reading anim2.def......done
    Reading anim3.def......done
    Reading anim4.def......done
    Reading anim5.def......done
    LoadArchivedTexture( "graphics/gold_dragon.png" ) failed
    Initializing Map...done ( 00:00:00.0679988 )
    Initializing Animations...done ( 00:00:00.0038655 )
    Initializing Gumps...done ( 00:00:00.0013480 )
    Initializing Hues...done ( 00:00:00.0068453 )
    Connecting to 104.153.105.151:****
    Graceful disconnect
    Done
     
  20. JamestheSame

    JamestheSame Member

    8
    2
    3
    Jul 13, 2017
    VajazzlinJames
    Hey guys, I found the information on how to set the mouse wheel for targeting. However, I can't find a macro file in the data folder within the Sallos folder. :)

    Where should I look for the macro file? I tried searching my computer but just found ultima online macro files.
     

Share This Page